#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "%%([\S\s]*?)%%"
Local $sString = "Dear {#var#}," & @CRLF & _
"Please find your Booking Confirmation details" & @CRLF & _
"Transcation ID : %%|TranscationID^{"inputtype" : "text", "maxlength" : "45"}%%" & @CRLF & _
"Truck No : %%|TruckNo^{"inputtype" : "text", "maxlength" : "15"}%%" & @CRLF & _
"From : %%|FromLoc^{"inputtype" : "text", "maxlength" : "30"}%%" & @CRLF & _
"To : %%|ToLoc^{"inputtype" : "text", "maxlength" : "30"}%%" & @CRLF & _
"Rent(INR) : %%|Fright^{"inputtype" : "text", "maxlength" : "8"}%%" & @CRLF & _
"Advance(INR) : %%|AdvanceAmt^{"inputtype" : "text", "maxlength" : "8"}%%" & @CRLF & _
"Loading Address : %%|LoadingAddre^{"inputtype" : "text", "maxlength" : "100"}%%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")