import Foundation
let pattern = #"%%([\S\s]*?)%%"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
Dear {#var#},
Please find your Booking Confirmation details
Transcation ID : %%|TranscationID^{"inputtype" : "text", "maxlength" : "45"}%%
Truck No : %%|TruckNo^{"inputtype" : "text", "maxlength" : "15"}%%
From : %%|FromLoc^{"inputtype" : "text", "maxlength" : "30"}%%
To : %%|ToLoc^{"inputtype" : "text", "maxlength" : "30"}%%
Rent(INR) : %%|Fright^{"inputtype" : "text", "maxlength" : "8"}%%
Advance(INR) : %%|AdvanceAmt^{"inputtype" : "text", "maxlength" : "8"}%%
Loading Address : %%|LoadingAddre^{"inputtype" : "text", "maxlength" : "100"}%%
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}