package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`%%([\S\s]*?)%%`)
var str = `Dear {#var#},
Please find your Booking Confirmation details
Transcation ID : %%|TranscationID^{"inputtype" : "text", "maxlength" : "45"}%%
Truck No : %%|TruckNo^{"inputtype" : "text", "maxlength" : "15"}%%
From : %%|FromLoc^{"inputtype" : "text", "maxlength" : "30"}%%
To : %%|ToLoc^{"inputtype" : "text", "maxlength" : "30"}%%
Rent(INR) : %%|Fright^{"inputtype" : "text", "maxlength" : "8"}%%
Advance(INR) : %%|AdvanceAmt^{"inputtype" : "text", "maxlength" : "8"}%%
Loading Address : %%|LoadingAddre^{"inputtype" : "text", "maxlength" : "100"}%%`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}