import re
regex = re.compile(r"%%([\S\s]*?)%%")
test_str = ("Dear {#var#},\n"
"Please find your Booking Confirmation details\n"
"Transcation ID : %%|TranscationID^{\"inputtype\" : \"text\", \"maxlength\" : \"45\"}%%\n"
"Truck No : %%|TruckNo^{\"inputtype\" : \"text\", \"maxlength\" : \"15\"}%%\n"
"From : %%|FromLoc^{\"inputtype\" : \"text\", \"maxlength\" : \"30\"}%%\n"
"To : %%|ToLoc^{\"inputtype\" : \"text\", \"maxlength\" : \"30\"}%%\n"
"Rent(INR) : %%|Fright^{\"inputtype\" : \"text\", \"maxlength\" : \"8\"}%%\n"
"Advance(INR) : %%|AdvanceAmt^{\"inputtype\" : \"text\", \"maxlength\" : \"8\"}%%\n"
"Loading Address : %%|LoadingAddre^{\"inputtype\" : \"text\", \"maxlength\" : \"100\"}%%")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")