// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"%%([\S\s]*?)%%").unwrap();
let string = "Dear {#var#},
Please find your Booking Confirmation details
Transcation ID : %%|TranscationID^{\"inputtype\" : \"text\", \"maxlength\" : \"45\"}%%
Truck No : %%|TruckNo^{\"inputtype\" : \"text\", \"maxlength\" : \"15\"}%%
From : %%|FromLoc^{\"inputtype\" : \"text\", \"maxlength\" : \"30\"}%%
To : %%|ToLoc^{\"inputtype\" : \"text\", \"maxlength\" : \"30\"}%%
Rent(INR) : %%|Fright^{\"inputtype\" : \"text\", \"maxlength\" : \"8\"}%%
Advance(INR) : %%|AdvanceAmt^{\"inputtype\" : \"text\", \"maxlength\" : \"8\"}%%
Loading Address : %%|LoadingAddre^{\"inputtype\" : \"text\", \"maxlength\" : \"100\"}%%";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}