#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?://\S*|[^\d.]"
Local $sString = ""Facebook: 1500 followers " & @CRLF & _
"https://facebook.com/user/AccountName/ " & @CRLF & _
"Twitter: 2000 followers " & @CRLF & _
"https://twitter.com/AccountName/"" & @CRLF & _
""Facebook: 1500 followers " & @CRLF & _
"https://linkedin.com/user/a4df65b1" & @CRLF & _
"Twitter: 2000 followers " & @CRLF & _
"https://twitter.com/AccountName/""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")