import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://\\S*|[^\\d.]";
final String string = "\"Facebook: 1500 followers \n"
+ "https://facebook.com/user/AccountName/ \n"
+ "Twitter: 2000 followers \n"
+ "https://twitter.com/AccountName/\"\n"
+ "\"Facebook: 1500 followers \n"
+ "https://linkedin.com/user/a4df65b1\n"
+ "Twitter: 2000 followers \n"
+ "https://twitter.com/AccountName/\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}