$re = '`https?://\S*|[^\d.]`m';
$str = '"Facebook: 1500 followers
https://facebook.com/user/AccountName/
Twitter: 2000 followers
https://twitter.com/AccountName/"
"Facebook: 1500 followers
https://linkedin.com/user/a4df65b1
Twitter: 2000 followers
https://twitter.com/AccountName/"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);