re = /https?:\/\/\S*|[^\d.]/m
str = '"Facebook: 1500 followers
https://facebook.com/user/AccountName/
Twitter: 2000 followers
https://twitter.com/AccountName/"
"Facebook: 1500 followers
https://linkedin.com/user/a4df65b1
Twitter: 2000 followers
https://twitter.com/AccountName/"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end