// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?://\S*|[^\d.]").unwrap();
let string = "\"Facebook: 1500 followers
https://facebook.com/user/AccountName/
Twitter: 2000 followers
https://twitter.com/AccountName/\"
\"Facebook: 1500 followers
https://linkedin.com/user/a4df65b1
Twitter: 2000 followers
https://twitter.com/AccountName/\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}