package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?://\S*|[^\d.]`)
var str = `"Facebook: 1500 followers
https://facebook.com/user/AccountName/
Twitter: 2000 followers
https://twitter.com/AccountName/"
"Facebook: 1500 followers
https://linkedin.com/user/a4df65b1
Twitter: 2000 followers
https://twitter.com/AccountName/"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}