import Foundation
let pattern = #"https?://\S*|[^\d.]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"Facebook: 1500 followers
https://facebook.com/user/AccountName/
Twitter: 2000 followers
https://twitter.com/AccountName/"
"Facebook: 1500 followers
https://linkedin.com/user/a4df65b1
Twitter: 2000 followers
https://twitter.com/AccountName/"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)