import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\begin\\{(\\w+)\\}.*?\\\\end\\{\\1\\}|\\\\(?!begin|end)\\w+\\{\\w+\\}";
final String string = "\\questao{1}\n\n"
+ "\\begin{enumerate}\n"
+ "esse não\n"
+ "\\end{enumerate}\n\n"
+ "\\begin{enumerate}\n"
+ "esse sim\n"
+ "\\begin{enumerate}\n"
+ "enumerate dentro de outro, não funciona\n"
+ "\\end{enumerate}\n"
+ "\\end{enumerate}\n\n"
+ "\\questao{2}\n\n"
+ "\\begin{enumerate}\n"
+ "esse também não\n"
+ "\\end{enumerate}\n\n"
+ "\\begin{enumerate}\n"
+ "esse também sim\n"
+ "\\end{enumerate}\n\n"
+ "\\questao{3}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}