const regex = /\\begin\{(\w+)\}.*?\\end\{\1\}|\\(?!begin|end)\w+\{\w+\}/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\begin\\{(\\w+)\\}.*?\\\\end\\{\\1\\}|\\\\(?!begin|end)\\w+\\{\\w+\\}', 'gs')
const str = `\\questao{1}
\\begin{enumerate}
esse não
\\end{enumerate}
\\begin{enumerate}
esse sim
\\begin{enumerate}
enumerate dentro de outro, não funciona
\\end{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
esse também não
\\end{enumerate}
\\begin{enumerate}
esse também sim
\\end{enumerate}
\\questao{3}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}