# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\\begin\{(\w+)\}.*?\\end\{\1\}|\\(?!begin|end)\w+\{\w+\}"
test_str = ("\\questao{1}\n\n"
"\\begin{enumerate}\n"
"esse não\n"
"\\end{enumerate}\n\n"
"\\begin{enumerate}\n"
"esse sim\n"
"\\begin{enumerate}\n"
"enumerate dentro de outro, não funciona\n"
"\\end{enumerate}\n"
"\\end{enumerate}\n\n"
"\\questao{2}\n\n"
"\\begin{enumerate}\n"
"esse também não\n"
"\\end{enumerate}\n\n"
"\\begin{enumerate}\n"
"esse também sim\n"
"\\end{enumerate}\n\n"
"\\questao{3}")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.