import Foundation
let pattern = #"\\begin\{(\w+)\}.*?\\end\{\1\}|\\(?!begin|end)\w+\{\w+\}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
\questao{1}
\begin{enumerate}
esse não
\end{enumerate}
\begin{enumerate}
esse sim
\begin{enumerate}
enumerate dentro de outro, não funciona
\end{enumerate}
\end{enumerate}
\questao{2}
\begin{enumerate}
esse também não
\end{enumerate}
\begin{enumerate}
esse também sim
\end{enumerate}
\questao{3}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)