re = /\\begin\{(\w+)\}.*?\\end\{\1\}|\\(?!begin|end)\w+\{\w+\}/
str = '\\questao{1}
\\begin{enumerate}
esse não
\\end{enumerate}
\\begin{enumerate}
esse sim
\\begin{enumerate}
enumerate dentro de outro, não funciona
\\end{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
esse também não
\\end{enumerate}
\\begin{enumerate}
esse também sim
\\end{enumerate}
\\questao{3}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end