use strict;
my $str = '\\questao{1}
\\begin{enumerate}
esse não
\\end{enumerate}
\\begin{enumerate}
esse sim
\\begin{enumerate}
enumerate dentro de outro, não funciona
\\end{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
esse também não
\\end{enumerate}
\\begin{enumerate}
esse também sim
\\end{enumerate}
\\questao{3}';
my $regex = qr/\\begin\{(\w+)\}.*?\\end\{\1\}|\\(?!begin|end)\w+\{\w+\}/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}