#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)[a-z]{3,10}://[^/\s:@]{3,20}(?<!user):(?!example)(?!pass])[^/\s:@]{3,20}(?<!password)(?<!example)@(?!example)(?!127\.0\.0\.1)(?!localhost).{8,100}"
Local $sString = "mysql://admin:admin@something.com:3306/db_name\n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")