import re
regex = re.compile(r"(?i)[a-z]{3,10}://[^/\s:@]{3,20}(?<!user):(?!example)(?!pass])[^/\s:@]{3,20}(?<!password)(?<!example)@(?!example)(?!127\.0\.0\.1)(?!localhost).{8,100}", flags=re.MULTILINE)
test_str = "mysql://admin:admin@something.com:3306/db_name\\n"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")