using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)[a-z]{3,10}://[^/\s:@]{3,20}(?<!user):(?!example)(?!pass])[^/\s:@]{3,20}(?<!password)(?<!example)@(?!example)(?!127\.0\.0\.1)(?!localhost).{8,100}";
string input = @"mysql://admin:admin@something.com:3306/db_name\n";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}