re = /(?i)[a-z]{3,10}:\/\/[^\/\s:@]{3,20}(?<!user):(?!example)(?!pass])[^\/\s:@]{3,20}(?<!password)(?<!example)@(?!example)(?!127\.0\.0\.1)(?!localhost).{8,100}/m
str = 'mysql://admin:admin@something.com:3306/db_name\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end