import Foundation
let pattern = #"(?i)[a-z]{3,10}://[^/\s:@]{3,20}(?<!user):(?!example)(?!pass])[^/\s:@]{3,20}(?<!password)(?<!example)@(?!example)(?!127\.0\.0\.1)(?!localhost).{8,100}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"mysql://admin:admin@something.com:3306/db_name\n"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)