import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)[a-z]{3,10}://[^/\\s:@]{3,20}(?<!user):(?!example)(?!pass])[^/\\s:@]{3,20}(?<!password)(?<!example)@(?!example)(?!127\\.0\\.0\\.1)(?!localhost).{8,100}";
final String string = "mysql://admin:admin@something.com:3306/db_name\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}