#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\w.]+"
Local $sString = "{ run }" & @CRLF & _
"" & @CRLF & _
"{ run file1 }" & @CRLF & _
"" & @CRLF & _
"{run -abc file1.foo file2.bar }" & @CRLF & _
"" & @CRLF & _
"{ run -ab -ogg -fgg file1.baz file2}" & @CRLF & _
"" & @CRLF & _
"{run -f-a-ob file1 file2.biz}" & @CRLF & _
"" & @CRLF & _
"{ run -a -b }" & @CRLF & _
"" & @CRLF & _
"{ fun -a -b }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")