import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w.]+";
final String string = "{ run }\n\n"
+ "{ run file1 }\n\n"
+ "{run -abc file1.foo file2.bar }\n\n"
+ "{ run -ab -ogg -fgg file1.baz file2}\n\n"
+ "{run -f-a-ob file1 file2.biz}\n\n"
+ "{ run -a -b }\n\n"
+ "{ fun -a -b }\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}