re = /[\w.]+/m
str = '{ run }
{ run file1 }
{run -abc file1.foo file2.bar }
{ run -ab -ogg -fgg file1.baz file2}
{run -f-a-ob file1 file2.biz}
{ run -a -b }
{ fun -a -b }
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end