// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\w.]+").unwrap();
let string = "{ run }
{ run file1 }
{run -abc file1.foo file2.bar }
{ run -ab -ogg -fgg file1.baz file2}
{run -f-a-ob file1 file2.biz}
{ run -a -b }
{ fun -a -b }
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}