$re = '/[\w.]+/m';
$str = '{ run }
{ run file1 }
{run -abc file1.foo file2.bar }
{ run -ab -ogg -fgg file1.baz file2}
{run -f-a-ob file1 file2.biz}
{ run -a -b }
{ fun -a -b }
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);