const regex = /[\w.]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w.]+', 'gm')
const str = `{ run }
{ run file1 }
{run -abc file1.foo file2.bar }
{ run -ab -ogg -fgg file1.baz file2}
{run -f-a-ob file1 file2.biz}
{ run -a -b }
{ fun -a -b }
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}