import re
regex = re.compile(r"[\w.]+", flags=re.MULTILINE)
test_str = ("{ run }\n\n"
"{ run file1 }\n\n"
"{run -abc file1.foo file2.bar }\n\n"
"{ run -ab -ogg -fgg file1.baz file2}\n\n"
"{run -f-a-ob file1 file2.biz}\n\n"
"{ run -a -b }\n\n"
"{ fun -a -b }\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")