import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<='.*)\\bday(?=s\\b|\\b)";
final String string = "'*** This day is the day of all days\n"
+ " '*** This day is the day of all days\n"
+ " Dim day as integer 'so far so good today but maybe not another day\n"
+ " day=day+1 'a daystar is a planet visible in the east before sunrise\n\n"
+ "Regex is not perfect\n"
+ "text1.Text = \"'day\" ' we don't want to change that one\n";
final String subst = "night";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}