import Foundation
let pattern = #"(?<='.*)\bday(?=s\b|\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'*** This day is the day of all days
'*** This day is the day of all days
Dim day as integer 'so far so good today but maybe not another day
day=day+1 'a daystar is a planet visible in the east before sunrise
Regex is not perfect
text1.Text = "'day" ' we don't want to change that one
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"night"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)