const regex = new RegExp('(?<=\\'.*)\\bday(?=s\\b|\\b)', 'gm')
const str = `'*** This day is the day of all days
'*** This day is the day of all days
Dim day as integer 'so far so good today but maybe not another day
day=day+1 'a daystar is a planet visible in the east before sunrise
Regex is not perfect
text1.Text = "'day" ' we don't want to change that one
`;
const subst = `night`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);