#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:^|[^\/])kb([0-9]+)"
Local $sString = "If I have a value that isn't prefixed with a forward-slash, e.g KB12345, it'll match the number within." & @CRLF & _
"If that value is prefixed with a forward-slash it won't match, e.g: http://someurl.com/info/KB12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")