$re = '/(?:^|[^\/])kb([0-9]+)/mi';
$str = 'If I have a value that isn\'t prefixed with a forward-slash, e.g KB12345, it\'ll match the number within.
If that value is prefixed with a forward-slash it won\'t match, e.g: http://someurl.com/info/KB12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);