package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:^|[^\/])kb([0-9]+)`)
var str = `If I have a value that isn't prefixed with a forward-slash, e.g KB12345, it'll match the number within.
If that value is prefixed with a forward-slash it won't match, e.g: http://someurl.com/info/KB12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}