use strict;
my $str = 'If I have a value that isn\'t prefixed with a forward-slash, e.g KB12345, it\'ll match the number within.
If that value is prefixed with a forward-slash it won\'t match, e.g: http://someurl.com/info/KB12345';
my $regex = qr/(?:^|[^\/])kb([0-9]+)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}