const regex = /(?:^|[^\/])kb([0-9]+)/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[^\\\/])kb([0-9]+)', 'mgi')
const str = `If I have a value that isn't prefixed with a forward-slash, e.g KB12345, it'll match the number within.
If that value is prefixed with a forward-slash it won't match, e.g: http://someurl.com/info/KB12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}