import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[^\\/])kb([0-9]+)";
final String string = "If I have a value that isn't prefixed with a forward-slash, e.g KB12345, it'll match the number within.\n"
+ "If that value is prefixed with a forward-slash it won't match, e.g: http://someurl.com/info/KB12345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}