// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:^|[^\/])kb([0-9]+)").unwrap();
let string = "If I have a value that isn't prefixed with a forward-slash, e.g KB12345, it'll match the number within.
If that value is prefixed with a forward-slash it won't match, e.g: http://someurl.com/info/KB12345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}