import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+\\d+)";
final String string = "BEGIN:VCARD\n"
+ "VERSION:3.0\n"
+ "TEL;TYPE=VOICE,CELL;VALUE=text:+79068006291\n"
+ "END:VCARD\n"
+ "BEGIN:VCARD\n"
+ "VERSION:3.0\n"
+ "TEL;TYPE=VOICE,CELL;VALUE=text:+79961763119\n"
+ "END:VCARD\n"
+ "BEGIN:VCARD\n"
+ "VERSION:3.0\n"
+ "TEL;TYPE=VOICE,CELL;VALUE=text:+79028796733\n"
+ "END:VCARD\n"
+ "BEGIN:VCARD\n"
+ "VERSION:3.0\n"
+ "TEL;TYPE=VOICE,CELL;VALUE=text:+79630332596\n"
+ "END:VCARD\n"
+ "BEGIN:VCARD\n"
+ "VERSION:3.0\n"
+ "TEL;TYPE=VOICE,CELL;VALUE=text:+79068024291\n"
+ "END:VCARD\n"
+ "BEGIN:VCARD\n"
+ "VERSION:3.0\n"
+ "TEL;TYPE=VOICE,CELL;VALUE=text:+79521360575\n"
+ "END:VCARD\n"
+ "BEGIN:VCARD\n"
+ "VERSION:3.0";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}