import re
regex = re.compile(r"(\+\d+)", flags=re.DOTALL)
test_str = ("BEGIN:VCARD\n"
"VERSION:3.0\n"
"TEL;TYPE=VOICE,CELL;VALUE=text:+79068006291\n"
"END:VCARD\n"
"BEGIN:VCARD\n"
"VERSION:3.0\n"
"TEL;TYPE=VOICE,CELL;VALUE=text:+79961763119\n"
"END:VCARD\n"
"BEGIN:VCARD\n"
"VERSION:3.0\n"
"TEL;TYPE=VOICE,CELL;VALUE=text:+79028796733\n"
"END:VCARD\n"
"BEGIN:VCARD\n"
"VERSION:3.0\n"
"TEL;TYPE=VOICE,CELL;VALUE=text:+79630332596\n"
"END:VCARD\n"
"BEGIN:VCARD\n"
"VERSION:3.0\n"
"TEL;TYPE=VOICE,CELL;VALUE=text:+79068024291\n"
"END:VCARD\n"
"BEGIN:VCARD\n"
"VERSION:3.0\n"
"TEL;TYPE=VOICE,CELL;VALUE=text:+79521360575\n"
"END:VCARD\n"
"BEGIN:VCARD\n"
"VERSION:3.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")