const regex = /(\+\d+)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\+\\d+)', 'gs')
const str = `BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79068006291
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79961763119
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79028796733
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79630332596
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79068024291
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79521360575
END:VCARD
BEGIN:VCARD
VERSION:3.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}