import Foundation
let pattern = #"(\+\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79068006291
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79961763119
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79028796733
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79630332596
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79068024291
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79521360575
END:VCARD
BEGIN:VCARD
VERSION:3.0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)