use strict;
my $str = 'BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79068006291
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79961763119
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79028796733
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79630332596
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79068024291
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79521360575
END:VCARD
BEGIN:VCARD
VERSION:3.0';
my $regex = qr/(\+\d+)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}