$re = '/(\+\d+)/s';
$str = 'BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79068006291
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79961763119
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79028796733
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79630332596
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79068024291
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79521360575
END:VCARD
BEGIN:VCARD
VERSION:3.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);