# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\\)(?:\\{2})*(?:"[^\\"]*(?:\\.[^"\\]*)*"|'[^\\']*(?:\\.[^'\\]*)*')(*SKIP)(*F)|\h+//gm;t' <<< "2 + 2
2+2
f( \" \")
f(\" \")
f(\"Test \\"mystring\\" .\")
f(\"Test \\"mystring\\" .\")
f(\"' \", \" \")
f(\"' \",\" \")"