#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\\)(?:\\{2})*(?:"[^\\"]*(?:\\.[^"\\]*)*"|'[^\\']*(?:\\.[^'\\]*)*')(*SKIP)(*F)|\h+"
Local $sString = "2 + 2" & @CRLF & _
"2+2" & @CRLF & _
"f( " ")" & @CRLF & _
"f(" ")" & @CRLF & _
"f("Test \"mystring\" .")" & @CRLF & _
"f("Test \"mystring\" .")" & @CRLF & _
"f("' ", " ")" & @CRLF & _
"f("' "," ")"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)