using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(?:\\{2})*(?:""[^\\""]*(?:\\.[^""\\]*)*""|'[^\\']*(?:\\.[^'\\]*)*')(*SKIP)(*F)|\h+";
string substitution = @"";
string input = @"2 + 2
2+2
f( "" "")
f("" "")
f(""Test \""mystring\"" ."")
f(""Test \""mystring\"" ."")
f(""' "", "" "")
f(""' "","" "")";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}